Android有兩個版本的AVD已經從新版的SDK中排除,但是有部份已經完成的程式卻是用這兩個版號開發,在匯入專案(Project)時Eclipse會顯示「Unable to resolve target android-X(X為建立時版本)」。

目前Android 2.0(android-5)與2.0.1(android-6)這兩個短命的版本已經從新的SDK排除,至少我從R6開始就沒見過他們了。

修正的方法很簡單,修改專案資料夾內的「default.properties」文件,將「target」修改為手邊有的AVD版本。例如2.1是「android-7」,其他以此類推。

參考資料:
Unable to resolve target ‘android-5’
Android SDK Error: Unable to resolve target ‘android-X’

更新日期: 2017/05/03

喜歡這篇文章?立刻分享給朋友!